当前位置:首页>微思动态>详情
全国热线电话 400-881-4699

在线留言

【干货】思科设备配置新手篇--静态路由

发布作者:微思网络   发布时间:2018-10-10   浏览量:0

 由于网络的需求,大部分网络需要两台路由及两台以上。此时当客户机访问目标网络需跨越多个路由时就需要网络管理员在各路由器上去配置路由协议。而静态路由协议往往配置在网络较小而且不易变动的小规模网络中。



      路由就是把信息从源传输到目的地的行为。信息包就可以是看作是一个代,而路由就可以说是一张地图,路由表即为行走的路径。静态路由是管理员手动一条一条的配置,路由器之间不会相互学习路由表。当网络的拓扑结构或链路的状态发生变化时,网络管理员需要手工去修改路由表中相关的静态路由信息。静态路由信息在缺省情况下是私有的,不会传递给其他的路由器。当然,网管员也可以通过对路由器进行设置使之成为共享的。


一、静态路由的优点


1.对于路由器的CPU没有管理性开销
2.在路由器之间没有多余的宽带占用
3.管理员可以有选择的只允许访问特定网络增加了安全性

二、静态路由的缺点


1.网络管理员必须了解网络的整个拓扑结构,以正确配置这些路由
2.如果网络拓扑发生变化,管理员要在所有的路由器上手动修改路由表
3.不适合在大型网络中

三、配置静态路由的语法


router(config)#ip route {destination_network} {mask} {next-hop_address or exit_interface} {administrative_distance} {permanent}
#next-hop_address or exit_interface:如果该部分命令使用next-hop_address来指定前往目标网络的下一跳路由器地址,则其管理距离为1;如果使用exit_interface来指定前往目标网络的本地路由器出接口,则路由器将视其为直连路由(使用命令show ip route network可知此处管理距离也是1,是个特例)。需要注意的是在多路访问网络中,最好使用下一跳地址来配置静态路由。否则不管数据包的目标地址是否有效,每次数据包到达时,只要ARP缓存表中查找不到该地址的缓存条目就会触发一个ARP请求,又因为ARP代理在IOS环境下默认是打开的,这意味着路由器将会为每一个远程节点(非一个广播域)储存一条ARP高速缓存。
#administrative_distance:添加此部分命令可用于修改管理距离的默认值为任何1~255的整数。跟动态路由相配合可做备份路由,以防动态路由无法工作时造成网路不通(静态浮动路由)。
#permanent:此命令表示不管发生任何情况都将在路由表中保留这一路由条目。

四、用show ip route查看路由表


Router#sh ip route
......
Gateway of last resort is 16.1.1.1 to network 0.0.0.0

   16.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
S     16.8.8.0/27 [1/0] via 16.2.2.2     #S表示为静态路由;[1/0]表示[管理距离/度量值];via表示通过(某人), 凭借(某种手段)。这里指下一跳地址。
S     16.7.7.0/30 [1/0] via 16.2.2.2
C     16.2.2.0/30 is directly connected, FastEthernet0/0     #C表示为直连网络;directly表示直接地
C     16.1.1.0/30 is directly connected, Serial1/1

   172.16.0.0/30 is subnetted, 1 subnets
S     172.16.2.0 [1/0] via 16.2.2.2

   192.168.2.0/32 is subnetted, 1 subnets
C     192.168.2.1 is directly connected, Loopback1
S*     0.0.0.0/0 [1/0] via 16.1.1.1     #*表示此路由条目是缺省路由(即0.0.0.0/0任意网络,任意掩码的网络)。Cisco路由表中只要是*表示的均为缺省路由(这句话的意思是,在思科路由表中缺省路由的形式并不局限于0。0.0.0/0)。

五、配置案例

 

厦门CCNP培训时教的静态路由的配置有两种方法:带下一跳路由器的静态路由,和带送出接口的静态路由
router(config)#hostname A (更改路由器主机名)
A(config)#interface f0/0 (进入接口f0/0)
A(config-if)#ip address 192.168.1.1 255.255.255.0 (设置接口ip地址和子网掩码)
A(config-if)#no shutdown (启用接口)
A(config)#interface f0/1
A(config-if)#ip address 192.168.2.1 255.255.255.0
A(config-if)#no shutdown
×××以下二选一:
A(config)#ip route 192.168.3.0 255.255.255.0 f0/1(目标网段IP地址 目标子网掩码送出接口(路由器A))
或者
A(config)#ip route 192.168.3.0 255.255.255.0 192.168.2.2 (目标网段IP地址 目标子网掩码下一路由器接口ip地址)
×××
router(config)#hostname B
B(config)#interface f0/0
B(config-if)#ip address 192.168.3.1 255.255.255.0
B(config-if)#no shutdown
B(config)#interface f0/1
B(config-if)#ip address 192.168.2.2 255.255.255.0
B(config-if)#no shutdown
×××以下二选一:
B(config)#ip route 192.168.1.0 255.255.255.0 192.168.2.1
或者:
B(config)#ip route 192.168.1.0 255.255.255.0 f0/1(目标网段IP地址 目标子网掩码送出接口(路由器B))
×××
注1:此网络链路为以太网链路,如果是串行链路,送出接口也就是本地路由器的串行接口。
简明解释:ip route 192.168.3.0 255.255.255.0 192.168.2.2
这句话的意思是:在HOSTA上,路由器见到目的网段为192.168.3.0的数据包,就将数据包发送到192.168.2.2上
注2:ip route 指向一个就可,如果两个都配了,就是说将这个数据包从发fa0/1出去,而另一个说数据包发到这个ip(例如192.168.2.2)。两个重复。一般我们设置为指向IP。


返回顶部